Indigo Rose Software

Professional Software Development Tools

 
Results 1 to 8 of 8
  1. #1
    Join Date
    Oct 2003
    Location
    Spring Hill, FL
    Posts
    63

    Oops Page Objects Slow Hiding on page 2

    I have two pages with text boxes for each button. On Pre-Load I am hidding each box with the command below.

    Paragraph.SetVisible("Browse Documents Note", false)

    In the first page it works fine. When the user click on a button to jump to another page. The objects do hide but slow in the order they are scripted. They are not hiding on pre-load or on show.

  2. #2
    Corey is offline Indigo Rose Staff Alumni
    Join Date
    Aug 2002
    Posts
    9,746
    Hi, I can't spot a question anywhere in your post. FYI for stuff like this it's always best to upload an example file and clearly outline the answer you are looking for with a concise question. Thanks.

    Corey Milner
    Creative Director, Indigo Rose Software

  3. #3
    Join Date
    Oct 2003
    Location
    Spring Hill, FL
    Posts
    63
    Sorry you did not understand. I have 8 objects on a page. I have it set to hide the objects. When you click on that page all the objects are on the screen and then disappear one by one in the order in which this are scripted to hide instead of all being hidden before the page is displayed to the user.

    What type of file are you looking for? the am5 file?

  4. #4
    Corey is offline Indigo Rose Staff Alumni
    Join Date
    Aug 2002
    Posts
    9,746
    Sorry you did not understand. I have 8 objects on a page. I have it set to hide the objects. When you click on that page all the objects are on the screen and then disappear one by one in the order in which this are scripted to hide instead of all being hidden before the page is displayed to the user.
    Well certainly no one would have extracted that conclusion from your post so it's not an issue of not understanding. Anyhow I still don't see any questions in your post other than about the files (yes I am referring to AMS source files). To get answers you must ask a question, no way around that one...

    Corey Milner
    Creative Director, Indigo Rose Software

  5. #5
    Join Date
    Jun 2000
    Location
    Indigo Rose Software
    Posts
    1,946
    Hi GalacTek,

    On which event are you hiding the objects? "On Preload" or "On Show"? If it is On Show try switching to "On Preload".

    You might also consider wrapping your object hiding code with:
    Application.SetRedraw(false);
    ....Your code here...
    Application.SetRedraw(true);
    MSI Factory The Next Generation Intelligent Setup Builder

  6. #6
    Join Date
    Sep 2002
    Location
    Sol 3
    Posts
    3,159
    Originally posted by GalacTek
    Sorry you did not understand. I have 8 objects on a page. I have it set to hide the objects. When you click on that page all the objects are on the screen and then disappear one by one in the order in which this are scripted to hide instead of all being hidden before the page is displayed to the user.

    What type of file are you looking for? the am5 file?
    \

    GalacTek, don't forget that you can set the visibility of an object when you design the project and not have to rely on hiding them individually when you show a page. In the properties inspector under Attributes the option is Visible. Set that to false then your objects will not be visible by default. See if that makes a difference in jumping to page 2.

    With AMS5 one of the easier ways to share a project is to click on File > Export Project. This will export the project to a .apz file that can be uploaded to the forum (as long as it is not to big).

    Tigg

  7. #7
    Join Date
    Nov 2001
    Posts
    498

    Mark is right!

    I can confirm that what Mark is suggesting works. I had a similar issue and this resolved it:

    You might also consider wrapping your object hiding code with:Application.SetRedraw(false);
    ....Your code here...
    Application.SetRedraw(true);

  8. #8
    Join Date
    Oct 2003
    Location
    Spring Hill, FL
    Posts
    63
    Changing the Attributes visible=false works on all the objects. Strange how 1st pages works fine without that set on each text box. Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts