PROBLEM: AutoPlay Application Does Not Start Automatically

PROBLEM: AutoPlay Application Does Not Start Automatically

Document ID: IR04034
The information in this article applies to:
  • AutoPlay Media Studio 4.0
  • AutoPlay Menu Studio 3.0

SUMMARY

This article describes what to do if your built AutoPlay application does not start automatically when burnt to a CD-ROM.

DISCUSSION

So, you've built your CD-ROM, but the AutoPlay Menu does not appear to be working. Usually, you have just made an easily correctable error or omission. Run through the following diagnostics before seeking technical support.

  1. When you double-click on the autorun.exe file in the root of the CD-ROM, does the menu start up?

    NO: You did not copy all of the files over to the CD when you made it.
    YES: Go on to 2.

  2. Double-click on My Computer. Right-click on the CD-ROM icon. Does "AutoPlay" appear as a choice?

    NO: You did not include all of the required files. Explore the CD-ROM and make sure all of the following files are present:

    autorun.inf
    autorun.exe
    autorun.apm
    The DATA folder and its contents
    All of these files/folders must exist at the root level of the CD-ROM in order for the AutoPlay feature to function properly.

    YES: Go on to 3.

  3. Is the AutoPlay feature enabled for the CD-ROM drive?
  4. NO: Enable the AutoPlay feature:

    Windows 95/98/ME

    • Select: Start | Settings | Control Panel
    • Double click the System icon to open the System Properties dialog.
    • Select the Device Manager tab.
    • Expand the CD-ROM node (it is usually the one at the top).
    • Select the appropriate CD-ROM drive and click the Properties button.
    • Select the Settings tab.
    • Check the box that says Auto insert notification.
    • Click OK to accept the change.
    • Reboot your system.

    Windows NT/2000/XP

    • Select: Start | Run
    • Type "regedit" in the Open field.
    • Press the Ok button.
    • Browse to the: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\Cdrom Registry key
    • Change the value of the Autorun Registry value from 0x0 (AutoPlay feature disabled) to 0x1 (AutoPlay feature enabled)
    • Reboot your system.

    Note: This will change the settings for all users on the system. To change it only for the current user, edit the Registry key HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Policies\Explorer and set the Registry value NoDriveTypeAutoRun from 0xff to 0x95.

    YES: Go on to 4.

  5. Are you working on Windows NT with Power User or Administrator rights?

    NO: By default, only users logged on to Windows NT with Power User or Administrator rights are allowed to install software. In Windows NT, files with the .inf extension are considered Setup Information files. As a result, the Autorun.inf file is not initiated if you do not have Power User or Administrator rights. To work around this issue, log on to Windows NT as a Power User or Administrator.

    YES: Go on to 5.

  6. Have you rebooted the system without the CD-ROM in the drive?

    NO: Reboot without the CD-ROM in the drive and only insert it once the system is running and you have logged in.

    YES: Go on to 6.

  7. Insert your Windows CD-ROM (or any other CD-ROM that you know has an AutoPlay feature that works). Does that CD-ROM's AutoPlay feature work?

    NO: The AutoPlay feature is disabled (see Question 3) or not functioning on your system.

    YES: You have not created and/or copied your AutoPlay menu correctly.

  8. Do you have Multiple CD-ROM drives?
  9. YES: On some systems, the AutoPlay feature will only work on the first or master drive.

  10. Is your burner the only CD drive that you have?

    YES: Some packet-writing drivers lock and ignore AutoPlay notification. Try your CD on another system or disable the packet drivers according to your drive/software documentation.

KEYWORDS: AutoPlay Media Studio 4.0, AutoPlay Menu Studio 3.0, Autorun, Autostart, Problem, CD-ROM


Last reviewed: October 25, 2002
Copyright © 2002 Indigo Rose Corporation. All rights reserved.