Indigo Rose Software

Professional Software Development Tools

 
+ Reply to Thread
Results 1 to 2 of 2
  1. #1
    Join Date
    Nov 2012
    Posts
    3

    Using Japanese fonts on buttons

    I'm having some trouble assigning Japanese text to buttons and a text box on a dialog designed to show Japanese text only. Oddly, the dialog title display the Japanese just fine. In all cases, the Properties listing shows the correct Japanese text. I suspect the issue is with needing to set the font on the buttons and text box to one that supports Japanese. However, when I try to change to (for instance) MS Mincho (and following the advice of another thread, I set the "Script" dropdown to Japanese, I get this error:

    Invalid Font

    The font you have selected is either not a TrueType Font (TTF) or is registered in a non-standard manner: M S [some JA chars I can't copy/paste here]


    I would appreciate any advice here. The project is setup to support English and 10 other languages, so I hope the solution doesn't require configuring any global settings to use only Japanese.

  2. #2
    Join Date
    Apr 2005
    Location
    Tabo„o da Serra
    Posts
    3,417
    Quote Originally Posted by BrHartmann View Post
    I would appreciate any advice here. The project is setup to support English and 10 other languages, so I hope the solution doesn't require configuring any global settings to use only Japanese.
    You need to use ANSI encoded text, as Lua is not Unicode compatible. The proper exhibition of text in Japanese depends on setting of "Language for non-Unicode programs", found in the Region and Language applet in the Control Panel. If that setting is adjusted for English, for example, you won't be able to display Japanese properly on all objects / controls.

    Ulrich

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts