PDA

View Full Version : Help with new version ini



Blazed
04-18-2004, 10:43 AM
i have a verison of 3.2 right now as a ini checker. this is what my ini looks like right now
[Version]
CurrentVersion=3.2

i dont know how to make it download the update if its lower than 3.2 as the current version for example. if they have 3.0 and need to update to 3.2 it says your program isnt installed properly please try again.

what do i need to add to the uif to make it able to detect if a lower version is running to download the update here is what my uif is reading right now.

File name: %WinDir%\info.ini ("not the real dir ofcourse")
Section: Version
Value name: CurrentVersion
Operator: Equal to (=)
Compare to: 3.2

and when i try to add another line with the "OR" command with this under it ... and change the ini to say 3.0 it wont update to 3.2 it just gives the error for not installed properly

File name: %WinDir%\info.ini
Section: Version
Value name: CurrentVersion
Operator: Equal to (<)
Compare to: 3.0

Darryl
04-18-2004, 05:42 PM
In the Server File Utility one of the actions that is available is called "Latest Version". That will notify TrueUpdate that the only action that needs to be taken is to display the Already Updated screen.

Most of the time you will have two versions identified:

1) The latest version which you could have as:
Section: Version
Value name: CurrentVersion
Operator: Equal to (=)
Compare to: 3.2

The action that you want to take is the Latest Version action mentioned above.

2) The second version you want to have is something like:
Section: Version
Value name: CurrentVersion
Operator: Less than
Compare to: 3.2

The actions will then be whatever it takes to update your version to the current version of your software.

Hope that helps.

Darryl