PDA

View Full Version : cryptro plugin --> invalid source specified



pixel-kraft
02-21-2004, 03:09 AM
Hi
I use a backgroundsong and i don't want that everbody copy the file from CD and use it. So i endcrypt the .ogg file (i use another filetype to prevent hacking) and as startup action i use code like that:

Folder.Create(_TempFolder.."\\tempfolderx86");
Crypto.BlowfishDecrypt("AutoPlay\\Docs\\01.mus", _TempFolder.."\\tempfolderx86\\01.dat", "mypassword");


after that i use following action to load the file

Audio.Load(CHANNEL_USER1, _TempFolder.."\\tempfolderx86\\01.dat", true, true);

When i use the preview Button in AMS 5 it's allright.
But when i burn it on CD no sound plays. I included the
Application.getlasterror code and after that get the error
"Invalid source specified"

I copied all on Harddisk and there is no error.
What is the problem. I need help of course the projekt goes near to the end.

Thanks for your help

Greetings from germany

Chris

Corey
02-21-2004, 08:31 AM
FWIW anyone with a $35 soundblaster soundcard or better can easily capture the audio stream as a file. For example on my computer, I just set the record source to "What U Hear" using Windows volume control and then press record, it captures everything in 32 bit sound...

Corey Milner
Creative Director, Indigo Rose Software (http://www.indigorose.com)

pixel-kraft
02-21-2004, 01:24 PM
Yes, i know that anybody can capture the sound with some tools. The encrypted files are only for those people who want to get the music directly. And another point is, that in AMS there is the audio channel and a background channel with an ambient sound of a street café, so with the soundblaster it is only possible to capture the mix not the single music file.

I need a solution for the "invalid source" Problem. Is there a failure in the crypto plugin??? I hope everyone can help me or give me a better solution to put the musicfile on CD without that everyone can copy the file to their MP3-Archive.

I need help - Please

Thanks

Chris

pixel-kraft
02-21-2004, 02:13 PM
i got it!
i used the global variable "_SourceFolder"
Now it works. But i don't know why it work without the _SourceFolder varible from HD but not from CD