PDA

View Full Version : PROBLEM: Setup Hangs at Registering Fonts Stage



Support
09-19-2002, 10:38 AM
<HTML><HEAD><TITLE>PROBLEM: Setup Hangs at Registering Fonts Stage</TITLE></HEAD><BODY><h3>PROBLEM: Setup Hangs at Registering Fonts Stage</h3><b>Document ID: IR02002</b><hr>The information in this article applies to:<ul><li>Setup Factory 6.0</li></ul><hr><h3>SYMPTOMS</h3><p>Prior to Setup Factory 6.0, version 6.0.1.1, some Setup Factory 6.0 users reported a problem where a user's system would hang indefinitely during the setup process at the "Registering Fonts" stage of a setup routine.</p><h3>CAUSE</h3><p>This bug was caused while the setup was broadcasting a WM_FONTCHANGE message to all top-level windows. Some applications that were running would not process the message properly, however, and the setup routine would not proceed. This message was being broadcasted regardless of whether or not fonts were being installed.</p><h3>RESOLUTION</h3><p>The bug was fixed by setting a 2 second timeout per application while waiting for each application to respond. Now, if an application does not respond, the setup continues. As well, we have added an optimization so that the message is not broadcast unless fonts are installed.</p><h3>STATUS</h3><p>This bug was fixed for Setup Factory 6.0, version 6.0.1.1. It is now a closed issue.</p><p>KEYWORDS: font, register, hang, WM_FONTCHANGE</p><hr><FONT SIZE=1>Last reviewed: September 19, 2002<br>Copyright 2002 <A HREF="http://www.indigorose.com" target="blank">Indigo Rose Corporation</a>. All rights reserved.<br></FONT></BODY></HTML>