PDA

View Full Version : Shortcuts not created



jerilyn
11-13-2008, 10:17 AM
I have a client who claims that when they install our program that the shortcuts are not being created in the Programs menu. I can't duplicate the problem with the same software we created. Are there any environmental issues in Windows or something else that would preclude shortcuts from being created in the Programs menu? We are using SUF 7.0.

jassing
11-13-2008, 04:01 PM
I have a client who claims that when they install our program that the shortcuts are not being created in the Programs menu. I can't duplicate the problem with the same software we created. Are there any environmental issues in Windows or something else that would preclude shortcuts from being created in the Programs menu? We are using SUF 7.0.

could be a rights issue...
are you letting SUF 'auto create' the shortcuts, or are you creating them manually (Shell.CreateShortcut())?

The only time I've seen shortcuts "not" created have been either a rights issue or a poorly configured Shell.CreateShortcut command.

jerilyn
11-13-2008, 04:15 PM
Thx for your reply. I am just using the defaults provided by SUF 7 as far as the shortcuts are concerned. I know there is an option on the shortcuts page to allow for the "current user" or "all users" for shortcuts to be created. The default is "current user." I am not the programmer type, just taking whatever SUF offers as defaults. Any suggestions are appreciated. Thx again!

jassing
11-13-2008, 04:23 PM
Then I would look at rights. do they have the rights to create a shortcut?

get the install log file to see if that gives any clues.

jerilyn
11-13-2008, 04:47 PM
Thank you for your response. Again I am not the programmer type. Where do I check the "rights" area? It's interesting we have thousands of clients and only 1 has this problem. Thanks again for your help!

jassing
11-13-2008, 05:00 PM
It wouldn't be something in SUF you'd do -- it'd be something that the user would have to change on their side.
One way to do it is in suf to select "require administrator" under "system requirements"